Midori Browser Synchronisierung über owncloud oder NAS

Der Midori Browser ist ja gar nicht mehr so unbekannt und bei mir mittlerweile doch recht häufig im Einsatz. Ich mag den Browser einfach, da er sauschnell und sehr schlank ist.

Für alle die einen Browser fernab der Mainstream Konkurrenz suchen kann ich den Midori Broser nur empfehlen. Was mir bisher fehlte, war die Möglichkeit alle Browser Daten mit meinen Rechnern zu synchronisieren. Den Chromium nutze ich gar nicht mehr, da ich bei diesem gar keine Möglichkeit gefunden habe die Browserdaten über eigene Server zu synchronisieren. Beim Firefox geht es, ist aber nicht unbedingt trivial und auch fehleranfällig bei Versionswechseln. Hat aber halt den Charme, dass der Sync sogar auf dem Android Handy funktioniert.

Nun gut. Wieder zum Midori Browser. Die Möglichkeit der Synchronisierung ist so einfach, dass man direkt darauf kommen müsste. :-)

Midori speichert ALLE Daten in folgendem Ordner:

/home/user/.config/midori

Das einzige was man machen muss ist dieses Verzeichnis über seine owncloud zu synchronisieren. Somit hat man alle Bookmarks, Passwörter oder geöffneten Tabs über alle Rechner synchron.

Was auch prächtig funktioniert (ist aber nicht wirklich Synchronisierung) wenn man sich das Verzeichnis einfach auf sein NAS legt und den genannten Ordner einfach verlinkt. So zum Beispiel:

ln -s /home/user/NAS/midori/ /home/user/.config/

Fertig. :-)

 

Flattr this!

Linux Mint: Probleme mit autofs

Im Moment bin ich zeitlich leider sehr eingeschränkt. Aus diesem Grund spiele ich zur Zeit auch wenig mit neuen Distributionen herum, da ich auf ein stabiles System angewiesen bin.

Am Wochenende habe ich mein Notebook aus o.g. Gründen mit Linux Mint (mit Cinnamon Desktop) bestückt. Natürlich ist Linux Mint eine durchaus stabile Distribution, leider bin ich dennoch auf ein Problem im Bezug auf autofs gestoßen.

Bemerkbar machte sich das Ganze durch einfaches „Geht nicht“ :-)

Ein Blick ins Syslog brachte folgenden Fehler ans Tageslicht:

[autofs] syntax error in nsswitch config near [ syntax error ]

Aha….

Mit dem Fehler konnte ich erstmal gar nichts anfangen, gerade auch da ich alle Systeme immer über ein und dasselbe Skript konfiguriere…

Ein wenig googlen brachte dann die Lösung.

In die angemeckerte Datei

/etc/nsswitch.conf

muss folgende Zeile hinzugefügt werden:

automount:files

Warum das so ist, kann ich leider nicht erklären. Fakt ist, bei mir funktionierte autofs danach wieder wie gewohnt. :-)

Flattr this!